Please or Register to create posts and topics.

Dedicated server not getting listed

Page 1 of 2Next

Hello again,

It's me from the topic about moving server to a dedicated machine - worked great btw, was easy to just create the folder and then point to it using the manager!


Now however, after doing all that and making sure that the server can boot up with the mods I have on the server, it simply will not show up in the unofficial list of servers when launching the game from my gaming PC.

Dedicated machine is running Windows Server 2022 with Webview2, all the VC++ redistributables from 2013 and onwards, .NET FrameWork 4.8+
Gaming PC is running Windows 11

I believe I have done everything that's needed to be done but nothing works...

  1. I opened up the correct UDP and TCP ports in Windows Firewall:
  2. They are also forwarded in my router. IP-Address is changed on these forwarding rules to match my dedicated machine which has a static IP:
  3. It's the correct ports in the server config (not changed from the settings on my gaming PC)

  4. Amazon certificate as well as certificate revocation list is imported to certlm.msc -> Trusted Root Certificate Authority (this fixed the issue with server not being able to find the mods I had at the start)

According to the Network Utilities tool from my port forwarding are done correctly (they worked before when I used my Gaming PC, I simply switched the IP address to my dedicated server)

Is there anything I'm missing?


Hey in windows firewall have you created same rules for Outbound Rules ?
try to desactivate windows firewall just for test

I did try with Windows Firewall disabled on the server but it still won't list. Although I can't remember if I had done the certificate fixes before or after that.

I can try again with the firewall turned off.

What purpose does the outbound connection serve, if you know? Typically Windows allows for most outbound connections without rules. I can't see that my gaming PC has any outbound rules related to ASA but I will try that too, if disabling the firewall helps.



Be sure to search in


and check password protected


I’m not at home sorry for bad screenshots

network openings should not be made on your gaming machine but on the dedicated server that you are on a dedicated machine. The problem must come from there. The ports to open are also on the dedicated machine.

If you do not host the dedicated server on your gaming PC, all openings must be made where the server is hosted

you must concentrate your searches on the server not on your pc

Hey, sorry for the late reply - haven't been home this weekend. Thank you for your time though!

Just to be clear, all my configuration and troubleshooting are being done on my dedicated server. I only mentioned my gaming PC doesn't have any outbound rules configured since it worked on it previous to moving the server.


I have searched for my server in both Unofficial (which it previously showed up in) and in non-dedicated, but it doesn't show in either one. "Show password protected servers" aswell as "Show player servers" is ticked, but I have tried with both.

Are there any roles or features Windows Server 2022 needs in order to be accessible across the Internet, or across local LAN? IIS or something perhaps? I couldn't find anything about it on the official ark wiki (Dedicated server setup - ARK Official Community Wiki).


try  telnet from your gaming pc to your dedicated server on port 7777 7778 27015

open cmd and type


for exemple :

telnet 7777

And repeat

telnet 7778

telnet 27015


and send me the screenshot result

note enter the real ip adresse of you dedicated machine hosting the dedicated server


without knowing your architecture it is difficult to help you

for me you have a firewall or a port not redirected from the machine which hosts the dedicated server I do not know your network architecture if you can describe where is the dedicated server and the gaming PC at home in the cloud? the host?

Hey again,

So I figured it out and it had nothing to do with my port forwarding or Windows Firewall rules, they all worked as expected.

Previously I had installed the Amazon RSA 2048 M02 certificate file as well as the Certificate Revocation List, but then I read this passage on the official wiki a bit more closely:

At first I thought, surely that's not accurate, because I installed the r2m02.cer after 18 November 2023, and the certificate surely must have been renewed since then. Wrong.
The solution to all these troubles was to remove the certificate itself but keep the .crl-file (certificate revocation list) in certlm.msc aswell as certmgr.msc.

Here's the final config on my Windows Server 2022 machine for any other persons who wants to do this setup on their home network:

Installed software on machine:

  • Windows Server 2022 Standard edition
  • ASA Dedicated Manager
  • .NET Framework 4.8+ (can be installed via Windows server manager)
  • WebView2
  • VC Redist 2013-2022 (all of the versions, but you likely only need the latest)
  • Amazon Certificate Revocation List from NOTE! this has to be installed in the Trusted Root Certification Authorities-store

Windows Firewall Rules (these rules would also apply to any third party firewalls you may have)

  • Inbound connections for UDP (for general game connections to your server)
    Ports 7777-7778, 27015
  • Inbound connections for TCP (used for RCON)
    Port 27020
  • I specified the ArkAscendedServer.exe under "Programs and services"-tab for each of these rules

Router portfowarding

  • Both TCP and UDP for ports 7777, 7778 and 27015 to your servers IP-address
  • TCP only for port 27020 used for RCON, to your servers IP-address

Note! If you use any other ports in your Ark Ascended server settings then this has to be reflected in your own config.

Again, thank you so much Admin for taking your time to answer my questions and helping me troubleshoot it. You're awesome!

Good morning,
thank you very much for the detailed and complete feedback I am sure that it will help many other people I will pin it immediately

happy that your server is now working!

Page 1 of 2Next