Please or Register to create posts and topics.

Server not Starting or Impossible to Connect or Find Server

Page 1 of 2Next


The bandwidth needed increases linearly with players connected. Generally, for home connection class a 100Mb or better is highly recommended to support properly a good number of players. Specifically for VPS, each connected player may require up to 60KiB/s of bandwidth, shared across upstream and downstream, however, all is directly tied by server tick-rate and the complexity of the world save reached.

The server listens for incoming connections on the localports listed below. Ensure your network configuration (operating system firewall and router port forwarding) allows incoming connections to these ports and directs them to the host that will be running your dedicated server.

Port Purpose
UDP 7777 Game port
UDP 7778 Peer port (always Game port +1)
UDP 27015 Query port (for Steam's server browser only)
TCP 27020 RCON for remote console server access (optional)

Please note manual port forwarding may be needed since ShooterGameServer does not support UPnP or other automatic port forwarding protocols.

Multiple dedicated servers on the same host are supported. A common setup consists of assigning and forwarding ports incrementally.

Server instance Game port (UDP) Peer port (UDP) Query port (UDP) RCON port (TCP)
Server instance 1 7777 7778 27015 27020
Server instance 2 7779 7780 27016 27021
Server instance 3 7781 7782 27017 27022
Server instance 4
(completely different ports)
9999 10000 37015 32330
Note: Completely different ports are supported as well, with the only limitation the Steam server browser not be able to find game servers without providing also the query port if this goes above 27020.
Note: Peer port is used by Steam P2P protocol for in-game browser advertising (Epic instead uses 80 and 443 standard ports with TLSv1.2), in the past (between patch 213.0 and 311.78) it was used for direct UDP socket connections (now disabled) and so it is sometimes wrongly referred as raw UDP port.

Operating system


The server requires Microsoft Visual C++ 2013 Redistributable X64 version and the last revision of the DirectX End-User Runtimes (June 2010) to be installed. It is highly recommended to use a supported operating system by both Microsoft and Steam: this means Windows 10 Version 22H2 and beyond or Windows Server 2016 (or Windows Server 2012 with Extended Security Update support) and beyond.

Windows Server editions

Windows Server editions require additional setup to support  ARK: Survival Evolved dedicated servers featuring crossplay with EPIC/EGS clients as well to run any  ARK: Survival Ascended dedicated servers. Windows Server editions handle certificates and certificate revocation lists in a different way.

Since 18 November 2023, server owners need to manually install the certificate revocation list that can be obtained from (or just directly from The downloaded r2m02.crl file must be installed (right-click on the file) by selecting Place all certificates in the following store and selecting Trusted Root Certification Authorities. A system restart may be needed.

If before 18 November 2023 server owners installed the r2m02.cer certificate file and the server isn't showing up, that certificate must be removed from the system to properly allow the servers to be visible again. To remove the revoked certificate run (Windows + R) certmgr.mscand search for Amazon RSA 2048 M02 in Trusted Root Certification Authorities. The same must be done running certlm.msc. Finally, a system restart may be needed


if that doesn't help look at the @faithie detailed help here

Updated 03/21/2024

I've done all of this... still my server isn't showing up. I've been trying to figure this out for over a week now and I think I'm to the point of needing some help. Anyone help me diag? My ports are forwarded as listed above, MS VC++ and DX are both updated, I even tried installing the CRL.

My System:
i9-9900K, 32gb, Win 11 Pro, RTX 3090ti, 2x 2tb nvme. Firewall is temporarily disabled, but entries are made in both inbound/outbound. I am playing on the same system I'm hosting the server. Cannot view server using steam server viewer under, says no server found, same thing using my local ip instead Tried putting my computer in the DMZ and still nothing.

I just checked and my ASE server does work. Ports 7777, 7778, 27015, 32330 without being in DMZ. *Not running at the same time fyi*

ASA server does show its Status is green "Ticking loop" and has successfully started. Both server and games files are up to date. My network setup is Computer to 8pt Switch to Router/Cable Modem. I am searching for the game showing password protected servers under unofficial & nondedicated. Also trying to add it to favorites using Steam Server Viewer using 127, local ip, and ext ip, using all 3 ports. One weird thing to note, in Steam Game Server Viewer, where you can select which game to view "(Any game)" ASA is not listed, but ASE is listed twice.

Help? Maybe Trust Cert issue?


yes try the cert everything seems ok for the rest

Many servers that are not visible or discoverable do not have the Epic https root certificate installed on the server. This is because the ASA  dedicated communicates with the server list via https on the  port 443. And if there is no valid SSL certificate for Epic (hosted on AWS cloud) there is no communication.

And remember if you have done port forwarding to use your local static address rather than

Do you know which specifically are all required? I installed the Amazon RSA 2048 M02 along with the 2048 M02 CRL in machine and user. I also have Amazon Root CA 1, do I need any of the other ones? I don't see any with "Epic" in them, not sure that it's supposed to?

have you follow the @faithie detailed help here
you just need


Previously I had installed the Amazon RSA 2048 M02 certificate file as well as the Certificate Revocation List, but then I read this passage on the official wiki a bit more closely:

At first I thought, surely that's not accurate, because I installed the r2m02.cer after 18 November 2023, and the certificate surely must have been renewed since then. Wrong.
The solution to all these troubles was to remove the certificate itself but keep the .crl-file (certificate revocation list) in certlm.msc aswell as certmgr.msc.

Here's the final config on my Windows Server 2022 machine for any other persons who wants to do this setup on their home network:

Installed software on machine:

  • Windows Server 2022 Standard edition
  • ASA Dedicated Manager
  • .NET Framework 4.8+ (can be installed via Windows server manager)
  • WebView2
  • VC Redist 2013-2022 (all of the versions, but you likely only need the latest)
  • Amazon Certificate Revocation List from NOTE! this has to be installed in the Trusted Root Certification Authorities-store

So keep the revocation list ( ➡

and remove the old certificate run (Windows + R) certmgr.mscand search for Amazon RSA 2048 M02 in Trusted Root Certification Authorities. The same must be done running certlm.msc. Finally, a system restart may be needed ➡

I did follow those instructions to remove and replace with the new crl and added it to both local machine and current user. I also made sure to add the AmazonRootCA1.cer. I was unable to find it with the link to dev.epicgames so I did go straight to amazontrust to get it.

Question... even without the certificate shouldn't I be able to use Steam Game Server Viewer to manually add the favorite and have it find the server on my local network? I assume this would bypass 443?

Uploaded files:
  • crl.jpg

Tried this to look at the network traffic on those ports. Not sure if this helps much? This is my attempts at using the server browser to directly connect to the server via local ip and public ip.

Uploaded files:
  • ports.jpg
Page 1 of 2Next